Upgrading to 1.2.0

  • 1.2.0 introduces the Model Metadata storage to Seldon Deploy. To enable/disable the model metadata storage functionality with all required prerequisites follow the instructions. The quick overview of the changes is:

    • If you do not want the model metadata functionality disable it by setting metadata.pg.enabled in the Seldon Deploy helm chart to false. Not recommended since all model metadata related features will be unavailable.

    • Install a self-hosted or managed PostgreSQL solution (instructions).

    • Configure the connection details to the PostgreSQL instance by adding a metadata-postgres secret in the Seldon Deploy namespace (instructions).

    • Enable the model metadata storage by setting metadata.pg.enabled in the Seldon Deploy helm chart to true (instructions).

  • Detector components for outlier detection, drift detection and metrics are now moving out of the seldon-logs namespace and into the user namespaces. To handle this

    • The easiest way to migrate is to delete any existing detectors from the UI and recreate them after upgrade.

    • To see what detectors you have, do kubectl get ksvc -n seldon-logs. Also check kubectl get trigger -n seldon-logs.

    • Detectors will have -outlier, -drift or -metrics in their names. Each will have a ksvc and a corresponding trigger. The name and namespace of the model they are for will also be in the name.

    • If you find any issues while carrying out this process, please contact Seldon.

  • The ElasticSearch integration will now enable basic authentication by default.

    • This is controlled by the elasticsearch.basicAuth flag in the Seldon Deploy Helm chart.

    • To disable it (and revert to the default behaviour of <= 1.1.0), you can set its value as elasticsearch.basicAuth=false.

    • To keep it enabled and configure ElasticSearch’s user / password credentials, please check the ElasticSearch integration setup guide.

  • The Seldon Core version is now 1.9.1. See the Getting Started > Production Installation section for installation. A helm upgrade --install can be used to upgrade.

  • The demo drift detector has changed from gs://seldon-models/alibi-detect/cd/ks/cifar10-0_4_3 to gs://seldon-models/alibi-detect/cd/ks/cifar10-0_4_4. This is because the alibi version in Seldon Core is upgraded.